
Chapter 1 - Visual Interface
The Visual interface consists of the Ribbonbar, Design Window, Status Bar, and Sidebar. The following chapter is meant to provide an overview of the basic functionality and graphical
layout of each of these program components. Details will be discussed in subsequent chapters.



1.1 Design Environment
The Design Environment is the central element of the Visual interface and is where most user interaction takes place. It also serves as the gateway to all of the other elements. This is where
the lighting model is constructed and analyzed to develop a final design.

The Design Environment has four components;
Ribbonbar, Design Window, Sidebar, and Status bar.
 The Quick Access Toolbar is additionally located at the
upper left to hold common commands. Each element handles
a specific function that remains consistent throughout program
operation.

An overview discussion of each is provided in this chapter,
while specific command execution is discussed in other
chapters.
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1.1.1 Quick Access Toolbar
The Quick Access Toolbar in the upper left corner of the Design Environment provides convenient access to common commands in the Visual title bar.

Default commands are Save, Open, Print Editor, Undo, Redo, Calculate, and
Properties. The Quick Access Toolbar can be customized with commands
useful to each user by clicking the down arrow on the right side of the buttons.

 

See Customize Dialog for more information.
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1.1.2 Ribbonbar
The Ribbonbar is the graphical menu interface housing all Visual commands. The commands on each tab are sub-grouped into panels to make navigation easier. Using a Ribbonbar style
allows easier location of commands via images and text that then allows for more commands to be shown.

Common commands are located on the Home tab.
Subsequent tabs group commands into different function
families.

 

The presence of a small downward arrow below the button
graphic indicates a sub-menu is available for more detailed
selection.

For example, there are four options for placing a Calculation
Zone as shown at right.

 

When executing a command, the context-sensitive Properties
tab will appear. The Properties tab provides an interface for
the specification of command parameters.  As an example, the
Properties tab that appears after executing the Line
command is shown at right. This allows for the specification of
object parameters at creation.

 

The Lock in the upper right corner of the Ribbonbar makes
the Ribbonbar behave more like a menu system in that after
navigating to a tab and executing a command, Visual will return
to the Home tab. Otherwise, the selected tab continues to have
focus.

 

While executing Modify commands (Copy, Move, Erase,
etc) the Properties tab will display the Selection and Object
Filters panels. These buttons and checkboxes allow you to
decide which objects Visual  will "grab" if selected. For more
information about object selection, reference Selecting Objects.
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On command tabs, the View panel is shown to enable quick
use of those functions as the design is completed.

 

Visual shows the Instructions panel on the Properties tab to
provide step-by-step instructions related to commands.

 

For more information about navigation, reference Getting Started. For more information on each tab see The Command Tabs.
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1.1.3 File Menu
The File menu is a part of the Ribbonbar but functions like a traditional menu instead of as part of the ribbon. The File menu is where new projects are created, VSL files are opened and saved,
projects are verified with the Audit command, DWG and DXF files are imported and exported, and the Print Editor is accessed.

After clicking the File menu button, a drop-down menu will appear allowing further
selection of several commands.

The presence of an ellipsis (...) following a menu command indicates that the
command provides access to a dialog form, most of which should be familiar to users
of other Windows-based applications.

The presence of a small right-arrow indicates that further command specification is
required in the form of a sub-menu, and placing your mouse over that item will cause
the sub-menu to appear at which point a selection can be made.

 

For more information see specific File Commands in the Chapter 12.
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1.1.4 Command Tabs
Tabs group commands into different function families that align with the modeling process; construct objects, possibly modify them, then define luminaires, place calculation zones, and finally view
the model. The commands on each tab are sub-grouped into panels to make navigation easier.

The Home tab contains common commands and sub-menus
used the most. Remember that the presence of a down arrow
means there is a sub-menu present; hover the mouse over
buttons to see the sub-menu.

 

The Construct tab contains commands used to build a model.
There a panels for both solid object commands and reference
object commands. The Navigation panel is included to change
the view.

 

The Modify tab contains two kinds of commands to modify the
design: some commands create objects from other objects and
others modify the base object. The Navigation panel is
included to change the view.

 

The Luminaire tab contains commands to build a Luminaire
Schedule, place Luminaires, and modify Luminaire display.
The View panel is included to change the view.

 

The Calculations tab contains commands to place Calculation
Zones and remove (Mask) points from those zones to fit
detailed scenarios, insert Power Density Zones, and sub-divide
Calculation Zones into different Statistical Zones if necessary.
This is also where the design is Calculated and Rendered. The
Navigation panel is included to change the view.

 

The View tab contains commands to change how the model
appears, provides access to saved views, and provides  in-depth
navigation commands to manipulate how the model is viewed.
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The Tools tab contains links to web-based design tools,
measurement commands, and buttons to initiate dialogs to
change Visual options.
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1.1.5 Design Window
The Design Window comprises the majority of the Design Environment screen. This is where lighting models are constructed, displayed and analyzed.

Think of the Design Window as the view port to the lighting
model. There are a number of ways to manipulate the view
port. It can be translated (left, right, up, or down), moved
rotationally around the lighting model (also referred to as
"orbiting"), and zoomed in and out. See View.

In Visual, the mouse cursor is a set of crosshairs colored for
identification. The cursor changes to the standard arrow when
it is outside the Design Window. See Mouse Pointer
Navigation.

The Global Axis icon in the lower left of the Design
Window can be turned on or off as desired. See
Environment Settings.

 

 

For more information, reference Getting Started.
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1.1.6 Status Bar
The Status bar is located at the bottom of the Design Environment screen, and provides continual feedback, handy tools, and command entry. The Status bar is always present at the bottom
of the screen and contains various buttons and feedback mechanisms to make designing easier. A toggle button with a gold color indicates the mode associated with that button is in operation as
is shown below for Snap Mode.

The purpose of the Command Line is to provide dynamic feedback and allow
coordinate entry related to commands during program operation. Once a command
has been initiated, the Command Line prompts the user for subsequent information
such as coordinate and object selection. In certain cases, numerical coordinate entry
is supported and the Command Line will convert to a text box to allow such data to
be entered manually (as shown for the Move command).  For more information,
reference Entering Coordinates.

 

Absolute Coordinates reports the exact location (Cartesian X,Y,Z) of the mouse
crosshairs within the modeling space with respect to the origin (0,0,0). For more
information see Cartesian Coordinates.

 

Relative Coordinates reports the location (Cartesian X,Y,Z) of the crosshairs within
the model space relative to a previously selected coordinate while in a command.
Visual additionally displays polar coordinates (distance and an angle). Relative
Coordinates are only reported for subsequent coordinate selections and are useful
when relative distances are more convenient or intuitive than absolute locations. For
more information also see Cartesian Coordinates.

 

The View Angles section shows reference angles for how the lighting model is
currently being viewed.

 

The Orthogonal Mode button allows the Orthogonal Mode to be turned on or off
and indicates the mode is active when it has a gold background. This mode restricts
movement to being perpendicular or parallel to the coordinate axes.

 

The Snap Mode button is a toggle button that allows the Snap Mode to be turned
on or off and indicates the mode is active when it has a gold background. The Snap
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Increment combo box indicates what increment Visual will use if that mode is
activated. Clicking the small down arrow initiates the list box for common selections
(part of which is shown at far right. Custom values can be typed into the box. See
Incremental Snap for more information.

The Object Snap buttons allow specific modes to be activated that help to draw
objects more accurately. The icons provide visual cues to the modes of: endpoint,
midpoint, center, intersection, and perpendicular. A mode is active when it has a gold
background. See Entering Coordinates for more information.

 

The Zoom buttons allow the quick change of the view by: Zoom All, Zoom
Window, Zoom Previous, Zoom In, Zoom Out, and Zoom to Center. For more
information see Zoom and Basic Viewing.

 

The Align Cursor to Plane and Align Cursor and Plane to Current View
buttons allow for easier construction of objects in specific planes. See

 

The Calculation Status and Mode indicates whether an interior or an exterior
scheme will be used and if only direct illuminance will be calculated or if interreflected
illuminance will also be calculated and presented. This field also displays units that are
used; this can be feet or meters for length and footcandles or lux for illuminance. Left-
click this field to display information about the last calculation time.

 

Calculation Type shows if electric lighting only or electric and daylighting is/are
calculated. Daylighting is an additional module that can be included in Visual. See
www.visual-3d.com for more information on installing daylighting capability.

 

Luminaire Counter as the name implies, provides an up-to-date count of the total
number of luminaires in the lighting model.

 

 

javascript:TextPopup(this)
file:///C:/Users/Eric/AppData/Roaming/verychmzip/Chapter_2_Getting_Started/2.9_Incremental_Snap.htm
file:///C:/Users/Eric/AppData/Roaming/verychmzip/Chapter_2_Getting_Started/Entering_Coordinates/2.10_Entering_Coordinates.htm
file:///C:/Users/Eric/AppData/Roaming/verychmzip/Chapter_12_Commands/View_Commands/Zoom.htm
file:///C:/Users/Eric/AppData/Roaming/verychmzip/Chapter_9_View/9.2_Basic_Viewing.htm
file:///C:/Users/Eric/AppData/Roaming/verychmzip/Chapter_9_View/9.5_Align_to_Plane.htm
file:///C:/Users/Eric/AppData/Roaming/verychmzip/Chapter_9_View/9.6_Align_to_View.htm
javascript:TextPopup(this)
javascript:TextPopup(this)
javascript:TextPopup(this)
javascript:TextPopup(this)
javascript:TextPopup(this)
javascript:TextPopup(this)
http://www.visual-3d.com/software/download.aspx
javascript:TextPopup(this)
javascript:TextPopup(this)
javascript:TextPopup(this)


1.1.7 Proper/es Tab
When executing commands, Visual will display the Properties tab in the Ribbonbar. This part of the Ribbonbar is a dynamic feature that allows unique attributes such as text description,
reflectance, and height to be assigned to objects as they are being created.

The Properties tab is considered dynamic because its
contents change depending on the active command.

Specific elements of the Properties tab are discussed in the
related section for each command that displays the tab.

 

The Properties tab works in conjunction with the Command Line in the Status bar to provide complete command specification while holding parameters constant that might be used with that
command upon the next execution.

For example, specifying a 9ft luminaire mounting height when
placing luminaires in one instance is likely to be applicable the
next time the command is used.

Specifying a parameter does not change the Visual defaults.

 

In commands where objects need to be selected, the Properties tab will include the Selection, Selection Filters, and View panels.

The Selection and Selection Filters panels assist in
selecting objects. See Selecting Objects for more information.

The View panel is simply the Navigation panel as described
in Basic Viewing.

 

The Properties tab is separately shown when executing the Properties command. In this mode, additional tools are provided for advanced object selection.

In addition to the Selection and Selection Filters panels, the Properties tab will
contain the Filters and Selection Modes panels that allow for further refinement of
what objects Visual will add to the selection set. See Ribbonbar Properties Tab for
more information.

 

More information on specific Properties tab tools and function is included as necessary in this document as commands are discussed.
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1.1.8 Sidebar
The Sidebar provides convenient access to three tabs of information that also allow for the modification of model object parameters and the display of calculation results.

The Layers tab contains the Layer Manager that controls the basic system layers
as well as user-defined layers related to properties and visibility. See Layer Manager
for more information.

Most layer functionality is considered an advanced topic; layer functionality in Visual
can be quite robust and complex. Complex designs can however be completed with
simply the default System Layers and modest if any use of this dialog.

 

The Properties tab displays context-sensitive fields to control the four object types
individually or in groups. When objects are selected, all parameters that can be user-
modified will be displayed. See Properties for more information.

As with the Layers tab, most use of this dialog is an advanced topic.

The display name on the tab itself will change depending on which object type is being
edited; for example, the tab will display "Luminaires" when Luminaires have been
selected for modification. When different object types are selected, the tab will display
"Shared Properties".
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The Statistics tab displays information related to the various Calculation Zones
and Statistical Zones placed in the model.

The typical statistical information is displayed, but additional fields can be added in the
Settings dialog. See Calculations Settings.

Clicking on a zone name will show the basic properties for that zone at the bottom of
the tab. See Statistics for more information.

Use of the Statistics tab is a basic function in the use of Visual.

 

The Sidebar can be resized by left-click-drag after clicking the divider between the
Design Window and the Sidebar. The cursor will change to a "double slider" to
indicate the operation can occur.

 
       (shown 2x normal size)

On occasion, Microsoft Windows and Visual don't communicate properly. This most
often results in the tabs at the bottom of the Sidebar disappearing. To fix this issue
see Reset Windows. This also resets the width of the Sidebar if it has been changed.
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 1.1.9 Command Line
One of the most important parts of the Status Bar is the Command Line. The Command Line provides feedback for each command related to necessary user inputs and allows for the input
of coordinate information if desired.

Commands have a step-by-step process that must be followed. The Command
Line provides text cues related to what type of input Visual needs to proceed.
Examples being "Select Objects" and "Base Point (X Y Z)".

Reading the Command Line provides on-the-fly command reference as does the
Instructions panel on the Properties tab of the Ribbonbar. Related information
can be found in Selecting Objects.

 

Note that all commands are moved from one step to the next by right-clicking the
mouse or pressing the Enter key.

See Using the Mouse and Keyboard Commands for detailed information.

 
  

The Command Line is where coordinate information is input via the keyboard. It may
be necessary to left-click on the Command Line to tell Visual to place focus there to
accept input if focus has been previously placed somewhere in the Properties tab.

See Command Line Entry for detailed information.
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 1.2 Se3ngs Form
The Settings form is accessed through the Tools tab of the Ribbonbar. This is where parameters affecting the global operation of Visual are found.

The Settings form provides a means for customizing the interface to meet specific
needs and/or user preferences.

Category selection is made from the tabs and the available options are shown in
panels in each tab. Settings are logically grouped and labeled for easy identification
within each category tab.

Graphics are included where appropriate.

 

For more specific information related to the use of the Settings form or any of the Visual options, reference Settings Dialog.
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1.3 Customize Form
The Customize form is accessed through the Tools tab of the Ribbonbar.

This multi-tab form is where you set the more program-specific options such as
making a custom toolbar, modify Quick Access toolbar buttons, assign or change
keyboard shortcuts, and change how menus behave.

 

For more specific information related to the use of the Customize form or any of the Visual options, reference Customize Dialog.
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1.4 Luminaire Schedule
The Luminaire Schedule is accessed through the Luminaire tab of the Ribbonbar. This is where the luminaire schedule is constructed to establish the various luminaire configurations
available for use within the Design Environment.

Luminaire Types are arranged in a scrolling spreadsheet format for easy and
intuitive assignment of photometric information, symbols, descriptions, and design
templates.

Photometric and descriptive information is accessed by selection of a valid
photometric file, and you may then modify the symbol, assign templates as
appropriate, and view a photometric report. Schedules can also be imported and
exported in a VSC format only useful in Visual or exported in a CSV format for use in
various spreadsheet programs.

 

When selecting a new Luminaire, Visual opens the Select a Photometric File
dialog that is more complex but yet considerably more useful than the standard
Windows dialog used for file selection elsewhere.

Visual includes an Acuity Brands photometric database but IES files from any
manufacturer can be selected. When using Acuity Brands files, the dialog shows
additional product information and graphics to make selection easier.

All IES files in a directory chosen in the left pane will be displayed in the upper right
pane in a list format showing key parameters. After left-clicking a filename, Visual will
display basic photometric information in the lower panel.

 

Once a photometric file has been chosen, it is possible to modify the Symbol by left-
clicking the Symbol in the Luminaire Schedule, which initiates the Luminaire
Editor. Visual chooses a Symbol that most closely resembles the basic form of the
luminaire based on the luminous dimensions in the IES file, but any Symbol can be
chosen.

 

The Luminaire Editor additionally allows for the selection and basic modification of
complex solid models for Shaded and Rendered views. Models are included and
automatically selected for Acuity Brands products. The inclusion of models for other
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manufacturers is a manual process that first requires a valid model file to be available;
creation is explained in the Luminaire Solid Models appendix.

For more specific information related to the use of the Luminaire Schedule, reference the Luminaire chapter.
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1.5 Print Editor
The Print Editor is accessed through the File option in the main menu. This separate window that opens on top of the main Visual window is where printable Pages are composed to illustrate
the lighting design built in the Design Environment.

Multiple Pages can be built with different to-a-scale views, snapshots, schedules,
notes, and statistics. Images, text, and PDF files can be placed, as well as
specification sheets and images for Acuity Brands products.

The Title Block is customizable with graphics, borders, and other elements to
provide a unique printed Pages if desired.

The layout and content of some elements can be saved as the default for future use.

 

For more specific information related to the use of the Print Editor, reference Print Editor.
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1.6 Upda/ng Visual
Updates to Visual are continually posted in order to improve program performance and address issues related to specific lighting model creation resulting from different user approaches to
construction.

When Visual is started, a license check is done via the internet. In that process,
version numbers are compared and Visual will display an Update Available button at
the right end of the Ribbonbar.

Clicking the button launches the Visual download page in a web browser to allow for
download.
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